Excel Gratis

Plantillas de Excel gratis, sin contraseñas

Calendario anual en hoja de Excel de cualquier año, sólo tenemos que introducir el año que deseado o también podemos cambiar los años en las flechas que se encuentran en Formato control, que van aumentando o disminuyendo un año según la flecha que seleccionemos. Este calendario puede servir de ayuda para confeccionar turnos u otro tipo de trabajo que deseamos hacer.
En la margen superior se encuentra el horario por turnos M (mañana), T (tarde) y N (noche), que los podemos modificar por otros.
Para que no se borren las fórmulas en las celdas la hoja se encuentra protegida, pero no contiene contraseña, por la que la puede desproteger cuando desee.
Notas a tener en cuenta:
Si cambia de año los días cambian de la columna donde se encuentran, pero los turnos no, porque debe borrar los turnos si no coinciden con el día que trabaja, ya que sumaría esas horas si no se borran.
El total mensual en lo que se refiere al número de turnos por mes suma todas las celdas desde la columna B hasta la columna AP1 que contiene texto)
También en el libro de excel que puede descargar en el enlace que se encuentra debajo de la imagen otro modelo de calendario de un solo mes que podemos ir cambiando el año y el mes y puede servir de ayuda u orientación para confecionar turnos u otro tipo de trabajo que deseemos.

Calendario para turnos

Descargar Calendario
Descargar calendario turnos- sin orientacion de los días

Hojas de Excel gratis

64 Responses so far.

  1. JORGE GARCIA says:

    REQUIERO PANTILLA PARA CUADRO DE TURNOS DE UN QUIROFANO

  2. Jose says:

    Hola amigos nesesito de su ayuda nesesito calcular que turnos diarios me podrian servir somos 3 personas, siempre deve deben aber 2 y uno con descanzo en los 31 dias del mes no. Importa el horario pero debe ser diario 2 personas siempre

  3. Manuel says:

    Buenas tardes, agradezco su ayuda en diseñar un turno con las siguientes condiciones:

    1.- Son 3 personas.
    2.- Se debe cubrir 24 horas el servicio.

    Que opciones de turno tenemos?

  4. Begoña says:

    Necesito ayuda para elaborar un calendario anual con los siguientes condicionantes:

    . 1 persona a turno de mañana de lunes a viernes. Fines de semana y festivos libres

    . 4 personas para cubrir el resto de turnos. T y noches de lunes a viernes y mañana, tarde y noche de sábado y domingo

  5. Maria fernanda juarez says:

    Buena noche necesito ayuda para elaborar rol de turnos del mes de diciembre. Necesito colocar 5 días librrs y 2 feriadis. Son 4 personas.

  6. Carlos says:

    Buenos días.

    Necesito ayuda para confeccionar turnos de trabajo de acuerdo a los siguientes datos:

    a) Son 4 personas.
    b) 3 turnos diarios (Mañana,Tarde y Noche).
    c) 45 horas semanales
    D) Se pueden hacer turnos semanales de 5 dias de 8 horas y 2 dias libres (cada trabajador debe tener 2 domingos al mes . Tambien se podria hacer turnos semanales de 6 dias de 7,5 horas y 1 dia libre semanal , debiendo tener 2 domingo al mes , domingo por medio.

    e) Se trabaja los 365 días
    d) Idealmente alternar los turnos, un mes de mañana y otro de tarde y otro de noche.

    e) Se necesita 1 persona por turno todos los días.

    Ojala puedan ayudarme , un saludo y muchas gracias

  7. Excel gratis says:

    Hola Jorge,
    En este caso no te puedo ayudar mucho al ser una tarea muy laboriosa en la cual deben coincidir el número de trabajadores para los trabajos rotatorios en los que incluye nocturnos en la cual deben dar el descanso correspondiente.
    Saludos

  8. Jorge López says:

    Buenos días.

    Necesitaría ayuda para confeccionar turnos de trabajo.
    Básicamente es lo siguiente.
    Tenemos 8 personas.
    Tenemos turno de mañana y turno de tarde.
    Se trabaja los 365 días
    Se alterna el turno, un mes de mañana y otro de tarde y viceversa.
    Necesitamos dos personas por turno todos los días.
    La libranza actual es:
    Lunes a Viernes
    Lunes a Domingo
    Semana libre
    Ahora hay tres colores de libranza: Rojo, Negro y Azul.
    Cada uno de los colores se encuentra en la situación de libranza descrita anteriormente: L-V L-D Semana libre
    El problema es que los fines de semana hay una persona sola. Hay una nueva instrucción de dirección que ninguna persona puede trabajar sola.
    Somos ocho pero se puede contemplar la posibilidad de aumentar el número de trabajadores para conseguir que en todo momento y todos los días de año haya siempre dos trabajadores.
    Espero que haya conseguido explicarme. Un saludo y muchas gracias

  9. angel bozal says:

    HOLA

    Necesitaria informacion para realizar CALENDARIO 2020 con 4º turno

    A B C D en rotaciones de

    2 MAÑANA 2 TARDE 3 NOCHES 2 FIESTA(LUNES MARTES)
    2 MAÑANA 3 TARDE 2 NOCHE 2 FISTA (MIERCOLES JUEVES)
    3 MAÑANA 2 TARDE 2 NOCHE 3 FIESTA (VIERNES SABADO DOMINGO)
    PODER CONTABILIZAR LOS SABADOS DOMINGOS ETC CON JORNADAS DE 8H
    Entiendo que tengo que ir metiendo todo a mano pero cuando metos dias vacios se me descuadra.

    Un saludo y gracias de antemano

  10. angel bozal says:

    Hola
    Necesito informacion de como meter 4 turnos A B C D mensualmente o anual en modo mensual metiendolo a mano e visto que se me descuadran unos meses con otros.

    Hacemos rotaciones de CUARTO TURNO
    2M 2T 3N 2 FIESTA (LUNES MARTES)
    2M 3T 2N 2 FIESTA
    3M 2T 2N 3 F

  11. Claudio says:

    Estimado, me puede ayudar necesito construir un calendario mensual de Turno, bajo las siguientes condiciones:
    – Mes Junio 2019
    – Total 10 personas
    – Dos Turnos de 8 horas mañana y tarde
    – Se requieren 3 personas por turno

    Favor si me puede ayuda, agradecido

  12. Excel gratis says:

    Hola Luis,
    Tienes que emplear la función CONTAR.SI para que te cuente los días trabajados y después los múltiple por las horas según el criterio deseado. En este caso daría el total de horas por mes, el que puedes ampliar el rango a todo el año.
    Fórmula existente en la plantilla para contar las horas por meses y turnos.
    =CONTAR.SI(B11:AH11;$AQ$3)*($AR$3+$AS$3/60)+CONTAR.SI(B11:AH11;$AQ$4)*($AR$4+$AS$4/60)+CONTAR.SI(B11:AH11;$AQ$5)*($AR$5+$AS$5/60)

    Por ejemplo, la fórmula anterior devuelve el total de horas trabajadas (los minutos los pasa a horas).

    1º cuenta el turno de M y lo multiplica por las horas + la suma (de minutos que pasa a horas)
    =CONTAR.SI(B11:AH11;$AQ$3)*($AR$3+$AS$3/60) nos devolvería el resultado en horas

    2º cuenta los turnos T lo multiplica por las horas + la suma (de minutos que pasa a horas)
    CONTAR.SI(B11:AH11;$AQ$4)*($AR$4+$AS$4/60)

    3ª cuenta los turnos de N lo multiplica por las horas + la suma (de minutos que pasa a horas)
    CONTAR.SI(B11:AH11;$AQ$5)*($AR$5+$AS$5/60)

    En este caso el rango que suma es desde B11 hasta AH11, los criterios para que cuente son los turnos están en la celda AQ3, AQ4 y AQ5, las horas en AR3, AR4 Y AR5, los minutos en AS3, AS4 y AS5, por lo tanto, puedes aumentar rangos de las celdas que desees que te busque para contar, así como distintos criterios.
    saludos.

  13. Luis says:

    a base de seguir tus instrucciones e indagar un poco he logrado crear esa columna y que según creo fecha se marque en el calendario. ahora necesitaría saber como hacer para crear en las celdas AQ35 y AR35 en la primera totales y en la segunda la suma de todas las horas en modelo anual. muchísimas gracias

  14. Excel gratis says:

    Hola Luis, te debería dejarlo modificar.
    Puedes probar de otras formas :
    Por ejemplo: seleccionas un rango de celdas por ejemplo AV9 hasta AV75 y le pones un nombre a este rango, después en Formulas-administrador de nombres borras festivo y cambias el nombre que has puesto por Festivo.
    También en administrador de nombres seleccionas Festivo y pulsas modificar, lo puedes modificar el rango existente pulsas la flecha de la derecha donde pone se refiere a y seleccionas seleccionas el rango que deseas, pulsas intro y aceptar.
    Espero que lo soluciones, saludos

  15. Luis says:

    muy buenas he seguido tus magnificas indicaciones, pero al intentar modificar el rango y aceptarlo me da error. ¿que puede ser? puede deberse a que debo introducir primero la formula y luego ir rellenando las casillas, en vez de hacer corta y pega?. Muchísimas gracias

  16. Excel gratis says:

    En fórmulas seleccionas administrador de nombres y seleccionas Festivo y modificar y cambias el rango que tiene por ejemplo lo puedes poner en la columna V desde rango V9:V75, como se indica a continuación =’Modelo (anual)’!$AV$9:$AV$75
    saludos.

  17. Luis says:

    querría cambiarlos en el modelo anual ¿¿como puedo hacerlo??muchas gracias

  18. Excel gratis says:

    Hola Luis, En la ficha menú fórmulas el nombre del rango que hace referencia a los festivos en la plantilla Modelo mensual es la siguiente: =’Modelo (mensual)’!$AT$7:$AT$35
    por lo tanto, se pueden introducir festivos hasta la fila 35 columna AT, en administración de fórmulas puedes ampliar el rango si lo deseas.
    saludos

  19. Luis says:

    bueno lo de modificar la tabla de turnos añadiendo una casilla mas “F” para no sacrificar ningún turno, ya esta gracias a un amigo. ahora quisiera modificar la tabla donde figuran los festivos para añadir más o poder cambiarla a otro sitio donde hubiera mas casillas para añadir, ya que los festivos anuales son 14 y solo figuran 8. espero que esto sea mas sencillo y pueda realizarlo siguiendo tus explicaciones. Muchas gracias por anticipado

  20. Excel gratis says:

    Hola Luis,
    Si lo deseas hacer de una forma sencilla sin cambiar mucho la plantilla, por ejemplo donde pone turno de mañana la puedes cambiar por D (Días trabajado) y en horas pones 8 en minutos 30, para los turnos de festivos cambias donde pone T por F(festivo) y pones las horas y minutos que deseas
    En el calendario pones si trabajas un festivo D y si no es festivo T y te daría la suma total del mes.
    Ejemplo:
    Celda AQ3 pones D y las horas en AR3 y los minutos en AS3
    Celda AQ4 pones F, y las horas en AR4 y los minutos en AS4
    Si para que nos cuente por ejemplo el rango B11:AF11, que donde ponemos debajo de cada día F o D, en este caso hace referencia a los festivos aplicamos la siguiente formula =CONTAR.SI(B11:AF11;AQ4)
    Para que cuente los demás días del mismo rango aplicamos la siguiente fórmula: =CONTAR.SI(B11:AF11;AQ3)
    Para nos cuente en el mismo rango donde hemos puesto F o D podemos aplicar las siguientes fórmulas que nos devolvería el mismo resultado, festivos: =CONTAR.SI(B11:AF11;”F”), demás días =CONTAR.SI(B11:AF11;”D”)
    Saludos

  21. LUIS says:

    Muy buenas, yo soy usuario nivel básico o menos aún. sobre este cuadrante me gustaría saber como poder añadir ciertas cosas:
    1.- Añadir más festivos
    2.- Que cada mes me contara las horas totales por los días que hubiera trabajado, contando como 8,5 horas cada día de trabajo.
    3.- Que los festivos trabajados tengan un valor X3 (8,5×17)

    en principio seria esto. GRACIAS

  22. Francisco says:

    Buenas noches, ya hice los cambios y he logrado que en la columna donde se van a contabilizar los festivos aparezca el cero, pero sigue sin contabilizar nada.
    Los días van desde la B7 a la AP7, los trabajadores van desde la A8 a la A37, los turnos irán desde la B8 hasta la AP37, los días festivos están puestos desde la AT7 hasta la AT21, la columna donde contabilizar los festivos va desde la AW8 hasta la AW37.

    la formula la he revisado y cambiado lo que me comentaste y en la columna AW 8 que seria el primer trabajador al ponerla sale 0 pero si vas poniendo M en los días festivos de un mes(ejemplo enero 1 y el 6) sigue sin modificar nada, sigue siendo 0

  23. Excel gratis says:

    Hola francisco, el rango de tu fórmula no figura la fila 8 que es donde deben estar los turnos. $B$7:$AP$8
    SI.ERROR(SI(BUSCARH(AT8;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)
    SI.ERROR(SI(BUSCARH(AT8;$B$7:$AP$8;2;FALSO)=”M”;1;0);0)
    tienes que cambiar en la fórmula el rango de los festivos o poner los festivos en el rango que se encuentra en la fórmula, en el rango que has indicado anteriormente.
    saludos

  24. Francisco says:

    te he de decir que para contabilizar los días festivos los tengo en una columna que va desde AW8 hasta AW37

  25. Francisco says:

    con la formula que me has enviado me pasa lo mismo que con la mía,no te merca ningún tipo de error, pero no sale tampoco nada

  26. Francisco says:

    Buenas noches, antes de nada agradecerte tu inestimable ayuda, que sin ella, seria imposible conseguir lo que estoy haciendo.He probado la formula en el turno de mañana, pero no me sale nada, no da error, ni nombre, ni valor, con lo cual imagino que la formula estará bien, pero no me da resultado, la formula es la siguiente

    =SI.ERROR(SI(BUSCARH(AT7;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT8;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT9;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT10;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT11;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT12;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT7;$B$7:$AP$13;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT14;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT15;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT16;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT17;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT18;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT19;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT7;$B$20:$AP$7;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(AT21;$B$7:$AP$7;2;FALSO)=”M”;1;0);0)

    no encuentro ningún fallo, pero algo tiene que fallar, porque no me funciona.

    por otra parte me gustaría saber si al cambiar de mes hay que borrar todos los datos, pues en el mes nuevo van a cambiar los días, cual seria la mejor manera para mantener los días trabajados por meses durante todo el año o la mejor forma de de poderlos guardar, para poder consultarlos con facilidad, ya que tengo distintas pestañas con distintas categorías de trabajadores

  27. Excel gratis says:

    Hola Paco, en este caso sería necesario un cuadrantes de turnos que conlleva muchas fórmulas y cierto tiempo.
    Turnos (M y T) con 3 dias de descanso
    Turnos (M Y N) 4 días de descanso.
    y al mismo tiempo coincidiendo 2 turnos .
    Saludos,

  28. Excel gratis says:

    Para los rangos que indicas para que te sume los turnos de mañana (M) copia y pega la siguiente fórmula, si tienes las fechas en las fila 7 desde B7 hasta AP7 y los turnos en la fila 8 desde B8 hasta AP8.
    Para sumar los dias festivos que ha trabajdo de mañana (M) aplicas a los rangos que indicas la siguiente fórmula:
    =SI.ERROR(SI(BUSCARH(AT7;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT8;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT9;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT10;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT11;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT12;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT13;$B$7:$AP$8;2;FALSO)="M";1;0);0)+SI.ERROR(SI(BUSCARH(AT14;$B$7:$AP$8;2;FALSO)="M";1;0);0)
    Para los turnos de tarde y noche remplazas en la fórmula M por T y N
    saludos

  29. Francisco says:

    los festivos los tengo en la columna AT7 a AT21 y los días van desde la B7 hasta la AP7

  30. Francisco says:

    Muchísimas gracias por la formula,se hace un poco liosa porque durante el año hay muchos festivos,pero la estoy desarrollando a partir de la tuya, ya que trabajo en el mensual y la había trasladado a otro rango.Otra posibilidad seria, que cambiase el festivo de color si coincidiese uno de los turnos de trabajo con el festivo, sino se quedase en blanco.por medio del formato condicional, no se si de ese modo puede ser mas corta y menos liosa la formula, o seria mas o menos igual, y si fuese mas fácil, como se podría hacer?

  31. Paco Trigo says:

    Buenas tardes. Trabajo en un hospital con turnos de 12 horas M y N. Con una cadencia de M N 3 descansos y M N 4 descansos. Cómo podría hacer para introducir esa formula en los 11 turnos que tenemos, teniendo en cuenta que siempre hay dos turnos coincidiendo (11 y 1; 1 y 2; 2 y 3…).
    También tenemos dos turnos fijos de mañana: 1.- lunes jueves y viernes 2.- martes y miercoles
    Muchas gracias

  32. Excel gratis says:

    De nada, gracias por tu visita, aquí te dejo unas fórmulas que te pueden servir de ayuda o referencia en referencia a los festivos
    Por ejemplo:
    Los festivos se encuentran en la la columna A rango A2:A9.
    En el calendario los días del mes se encuentran en la fila 10 rango B10:AP10
    Los turnos de trabajo en la fila siguiente fila 11 rango B11:AP11
    Para turnos de Mañana (M) aplicando la siguiente fórmula en el caso de que el festivo que hay en A2 coincide con la fecha del calendario que hay en la fila 10 y el turno sea de mañna (M), nos devuelve 1 en caso contrario 0.
    =SI.ERROR(SI(BUSCARH(A2;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)
    Si es turno de tarde (cambiamos en la fórmula “M” por “T”
    =SI.ERROR(SI(BUSCARH(A2;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)
    Para el turno de noche N
    =SI.ERROR(SI(BUSCARH(A2;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)
    Como nos devuelve 1 o 0 en el caso de coincidir, si aplicamos la siguiente fórmula sumaría todas las coincidencias para el turno de mañana (M),
    Festivos se encuentran en el rango A2 hasta la celda A9
    =SI.ERROR(SI(BUSCARH(A2;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A3;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A4;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A5;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A6;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A7;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A8;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)+SI.ERROR(SI(BUSCARH(A9;$B$10:$AP$11;2;FALSO)=”M”;1;0);0)
    Para el turno de Tarde
    =SI.ERROR(SI(BUSCARH(A2;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A3;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A4;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A5;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A6;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A7;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A8;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)+SI.ERROR(SI(BUSCARH(A9;$B$10:$AP$11;2;FALSO)=”T”;1;0);0)
    Para el turno de noche (N)
    =SI.ERROR(SI(BUSCARH(A2;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A3;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A4;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A5;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A6;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A7;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A8;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)+SI.ERROR(SI(BUSCARH(A9;$B$10:$AP$11;2;FALSO)=”N”;1;0);0)
    Por lo tanto, va buscando coincidencias si coinciden nos devuelve 1 y la suma a la anterior.
    saludos,

  33. FRANCISCO says:

    Muchas gracias por todo, esta formula me ha sido de gran ayuda, si pudieses ya la formula de festivos a turnos, ya seria el no va mas

  34. Excel gratis says:

    Hola Francisco,
    Por si te sirve de ayuda, si tienes los días en la fila 8 (desde B8 hasta AP9) y los turnos en la fila 9 ( desde la celda B9 hasta la celda AP9).
    =SUMAPRODUCTO(--(DIASEM(B8:AP8;2)=7);--(B9:AP9="N"))
    Si los turnos de noche estuvieran en la celda A1 se aplicaría la siguiente fórmula:
    =SUMAPRODUCTO(–(DIASEM(B8:AP8;2)=7);–(B9:AP9=A1)) en caso de que el turno de noches estuviese en otra celda se hace referencia a la celda donde se encuentre el turno (tiene que coincidir con los datos que se introducen en la fila 9 donde se indican los turnos
    (DIASEM(B8:AP8;2)=7) (el día de la semana que sea igual a domingo (7 para domingos – va de 1 para lunes a 7 para domingos)
    saludos

  35. francisco says:

    Buenas tardes, para explicarme mejor que en la anterior consulta, es que quiero averiguar los domingos que han trabajado una serie de trabajadores en turnos de mañana, tarde y noche y eso me aparezca en una columna contándome los domingos trabajados en el mes.Dependiendo del mes, los días de la semana irían de la B8 a la AP8, el rango de mes va desde la B8 hasta la AP37 la columna donde se contabilizaran los días
    va de la AV8 hasta la AV38.
    y adaptando la formula para que la noche del sábado sea contada como domingo en lugar de la del domingo que la contabilizo como lunes

  36. FRANCISCO says:

    GRACIAS POR LA FORMULAS, HE INTENTADO APLICAR LA FORMULA PARA SABER LOS DOMINGOS QUE SE HAN TRABAJADO MAÑANA, TARDE Y NOCHE, ADAPTANDO LA FORMULA A LA PLANTILLA MENSUAL, PERO ME SALE ERROR DE NOMBRE, Y NO SOY CAPAZ DE RESOLVERLO, A VER SI ME PUEDES AYUDAR.EL RANGO VA DE LA
    B8 HASTA LA AP37,DE ANTEMANO MUCHÍSIMAS GRACIAS POR TODO

  37. Excel gratis says:

    Hola Francisco, por si te sirve de ayuda o referencia aquí te dejo algunas fórmulas, por ejemplo pasar saber cuantos domingos ha trabajado de mañana (M) puedes emplear la siguiente fórmula
    E10=Fecha inicial
    AI10=Fecha final
    El rango desde E11 hasta AI11 es donde están los turnos Fórmula:
    =SUMAPRODUCTO(--(DIASEM($E$10:$AI$10;2)=7);--($E$11:$AI$11="M"))
    Para saber los domingos que ha trabajado turno de tarde (T)
    =SUMAPRODUCTO(--(DIASEM($E$10:$AI$10;2)=7);--($E$11:$AI$11="T"))
    Para saber los domingos que ha trabajado turno de tarde (N)
    =SUMAPRODUCTO(--(DIASEM($E$10:$AI$10;2)=7);--($E$11:$AI$11="N"))
    Para saber los domingos que has trabajado de mañana, tarde y noche:
    =SUMAPRODUCTO(--(DIASEM($E$10:$AI$10;2)=7);--($E$11:$AI$11="M"))+SUMAPRODUCTO(--(DIASEM($E$10:$AI$10;2)=7);--($E$11:$AI$11="T"))+SUMAPRODUCTO(--(DIASEM($E$10:$AI$10;2)=7);--($E$11:$AI$11="N"))

    Para contar los días que has trabajado de mañana sin contar los domingos
    =CONTAR.SI($B$11:$AP$11;"M")-SUMAPRODUCTO(--(DIASEM($B$10:$AP$10;2)=7);--($B$11:$AP$11="M"))
    Rango B11:AP11 es el rango donde se encuentran los turnos
    B10:AP10 es el rango de la fecha donde comprueba si el día es domingo y si ha trabajado de mañana.

    Para contabilizar los días festivos trabajados por turnos es un poco más laboriosa la fórmula que tendría que revisar más detenidamente.
    saludos

  38. francisco says:

    los de los domingos, festivos y noches no serian para contabilizar las horas, sino para saber cuantos domingos, festivos y noches ha trabajado un trabajador, ya que por festivo trabajado le pertenece un día y por los domingos y noches tienen suplemento

  39. Francisco says:

    Como podría añadir mas turnos, lo he hecho arrastrando y solo me acepta uno mas, seria posible añadir mas, tantos como me hicieran falta, ya que ademas de turnos quisiera poner los días de incidencias(enfermedad,asuntos propios,ect)

  40. Excel gratis says:

    Hola Francisco,
    La fórmula ya contabiliza las horas trabajadas, aunque sean festivos o domingos si debajo del día se encuentra el turno.
    Si tenemos en un rango de celdas ciertos ciertos días festivos desde la celda A2 hasta la Celda A8 y queremos saber los días festivos que hay desde la fecha inicial que se encuentra en la celda B10 y como fecha final AP10, aplicamos la siguiente fórmula:
    =SUMAPRODUCTO(–ESNUMERO(COINCIDIR(FILA(INDIRECTO(B10&”:”&AP10));A2:A8;0)))
    La siguiente fórmula nos indica los domingos que hay en un rango de fechas Fecha inicial celda E10 y fecha final celda AI10:
    =SUMA(ENTERO((DIASEM($E$10+7-{1})+$AI$10-$E$10)/7))
    o también =SUMAPRODUCTO(–(DIASEM(FILA(INDIRECTO($E$10&”:”&$AI$10));2)=7))
    Fórmula: Domingos Turnos de M
    =SUMAPRODUCTO((DIASEM($E$10:$AI$10;2)=7)*($E$11:$AI$11=”M”))
    =SUMAPRODUCTO(–(DIASEM($E$10:$AI$10;2)=7);–($E$11:$AI$11=”M”))

  41. Francisco says:

    que formula podría utilizar para que me contabilizase los domingos, festivos y noches trabajadas por el personal

  42. Excel gratis says:

    Hola Paulina, entiendo que tienes que hacer muchas combinaciones para que te devuelva el resultado deseado, ya que aparte de los turnos incluye también 2 días libres por semana.
    Por ello, tendría que verlo con más detenimiento, si a una fecha le deseas añadir 5 días puedes aplicar la siguiente fórmula si la fecha se encuentra en la celda A3
    =FECHA(AÑO(A3);MES(A3);DIA(A3)+5) si empieza a trabajar el día de la fecha que hay en A3 este sería de descanso.
    =FECHA(AÑO(A3);MES(A3);DIA(A3)+7) este día tendría que volver a trabajar después del descanso.
    para los días de semana =DIASEM(A3;2)<6 si la fecha que está en la celda A3 de lunes a viernes devuelve verdadero en caso contrario falso
    Saludos y suerte

  43. Paulina says:

    Hola como están, necesito ayuda con alguna formula y saber donde debo ponerla, debo realizar un turno rotativo mensual de 10 personas con M,T, Y N y que por semana tenga 2 dias libres por cada trabajador, me ayudarian con algún Tips

    Muchas gracias

  44. Excel gratis says:

    Hola Jorge,
    Si por ejemplo Tienes la fecha en la celda B10 y en la celda B11 tienes el turno y cubres los primeros 7 turnos y a continuación pones la siguiente fórmula condicionada y arrastras a donde pones los turnos del mes correspondiente.

    =SI(ESBLANCO(B11);"";SI(Y(B11="M";I10=B10+7);"T";SI(Y(B11="T";I10=B10+7);"N";SI(Y(B11="N";I10=B10+7);"L";SI(Y(B11="L";I10=B10+7);"M";" ")))))
    Si la celda B11 tiene el turno en blanco, deja la celda en blanco
    Si la celda B11 tiene el turno M y la celda I10 es igual a la fecha que hay en la celda B10 + 7, nos devuelve el turno T, si tiene el turno T nos devuelve el turno N, si tiene el turno N, nos devuelve el turno L, si tiene el turno L, nos devuelve el turno M.
    Esta fórmula está condiciona al contenido del la celda B11 y al contenido del celda B10 que es donde tiene la fecha.

    Saludos.

  45. Jorge says:

    Hola
    Me gustaría realizar las rotaciones de 4 turnos, M,T,N,L de tal forma que cada 7 días cambian el de M a T, el de T a N, el de N a L y el de L a M pero me encuentro con el problema que si yo en el primer mes los pongo y en el segundo mes modifico las 7 primeras casillas me modifica las mismas casillas del primer mes, en vez de quedarse bloqueadas las celdas por meses.

    Espero a verme explicado bien
    Saludos

  46. Excel gratis says:

    Hola Celeste,
    Lo más sencillo es una vez que tengas grabado todos los datos del año correspondiente lo que haces es des-proteger la hoja y grabar una Macro con esta hoja para que te la guarde en otra hoja y eliminar los eliminar los turnos y para que quede la hoja sin turnos.

  47. Celeste says:

    Estimado
    Me surge una duda con respecto a que macro debo hacer para que al cambiar de año la información de turnos se conserve y que al mismo tiempo sea distinta para todos los años, se puede realizar esta acción?
    muchas gracias

  48. Excel gratis says:

    Hola Fran,
    Al abrir el libro tienes 2 calendarios el anual y el mensual donde podemos añadir mas insertando filas y arrastrando las formulas hacia abajo para que coincidan con la fila correspondiente.
    En referente al comentario habría que añadir al final de la fórmula más condiciones para que sume más turnos.
    Por ejemplo si te pones en cualquier celda donde muestra las horas aparece una fórmula, ésta devuelve un resultado según la regla de validación que corresponde en este caso M, T o N,
    Si deseamos añadir uno más aparte de estos tendríamos 4, por ejemplo Turno E (horas 9) y minutos 30.
    Celda AR2: M
    Celda AR3: T
    Celda AR4: N
    Celda AR5: E
    Para que nos sume en la fila 8 antes tenía la siguiente fórmula: =CONTAR.SI(B8:AP8;$AR$2)*($AS$2+$AT$2/60)+CONTAR.SI(B8:AP8;$AR$3)*($AS$3+$AT$3/60)+CONTAR.SI(B8:AP8;$AR$4)*($AS$4+$AT$4/60)
    Ahora deseamos que nos cuente las horas del turno que hay en la celda AR5, añadimos una condición más a la fórmula anterior para que cuente las horas de los días que son iguales al contenido de la celda AR5 y sería la siguiente: CONTAR.SI(B8:AP8;$AR$5)*($AS$5+$AT$5/60), la fórmula entera quedaría así:
    =CONTAR.SI(B8:AP8;$AR$2)*($AS$2+$AT$2/60)+CONTAR.SI(B8:AP8;$AR$3)*($AS$3+$AT$3/60)+CONTAR.SI(B8:AP8;$AR$4)*($AS$4+$AT$4/60)+CONTAR.SI(B8:AP8;$AR$5)*($AS$5+$AT$5/60)
    Si deseamos añadir más turnos, tendrías que mover el cuadro donde se encuentran los turnos como mínimo 3 columnas a la derecha.
    Ejemplo:
    Seleccionamos el cuadro de turnos incluyendo las horas y minutos, insertamos para que se mueva hacia la derecha, después insertamos en el cuadro más turnos y que se muevan hacia abajo y aplicamos las fórmulas correspondientes en el calendario para que nos devuelva el resultado deseado.

  49. Fran says:

    Me gustaría utilizar tu tabla, aparte de para contabilizar las horas como cuadrante para 8 compañeros. ¿Puedo crear mas puestos aparte de los 3 predefinidos de M,T y N y que me los añada a la formula de la suma de horas automaticamente? Solo he sabido hacerlo a mano linea por linea. Gracias

  50. Excel gratis says:

    Comprueba si donde pones M, T y N coincide con el día que corresponde con el mes y año.

    Ejemplo:
    Si el año año 2016 el día 1 de enero has puesto un turno T, M, N y cambias de año para el 2017, como el día 1 no coincide en la misma fecha tacharía ese día.
    en formato condicional se encuentran los formatos aplicados.

  51. Igonzalez says:

    Buenos días,

    Estoy empleando sus plantillas para el calculo de la rotacion de turnos en cuatro equipos al mes.

    Al cumplimentar la rotación anual, hay celdas que me aparecen en rojo y tachadas.

    ¿Podrian indicarme porque ocurre esto?. No se se estoy incorporando algun dato de forma erronea.

    Muchas gracias Irene

  52. gabriel says:

    Buenas noches.
    No he trabajado muchos con el programa OpenOffice y no se donde puedo desproteger la hoja, porque cuando modifico y guardo, al abrir la hoja el año se me pone en 1900.
    Gracias.
    Un saludo

  53. Excel gratis says:

    Hola Bom, Por si te sirve de ayuda o refernecia, en este caso entiendo que tendría que aplicar una fórmula con una condición, en el caso que el día sea igual a viernes trabaja x horas, por ejemplo:
    Si tenemos la fehca en la celda A1, si aplicamos la siguiente fórmula las fechas que sean viernes devolvería que trabaja 5 horas el resto 7.
    =SI(DIASEM(A1)=6;5;7)
    El 5 o el 7 lo podemos cambiar por la cantidad desea o aplicar una fórmula en el caso de que el día sea igual a viernes .
    En el siguiente caso sumaría en el caso de que el día que hay en la celda A1 es igual a viernes sumaría 2+3, en caso contrario devolvería 8 =SI(DIASEM(A1)=6;2+3;8)
    SI(DIASEM(A1)=6;2+3;8)

  54. Bom says:

    Hola, gracias por su trabajo. Uno de mis trabajadores hace durante la semana turno de mañana pero el viernes tiene un turno partido en el que por la mañana trabaja menos horas. Como lo hago? Gracias

  55. Carlos says:

    Buenas tardes…
    Necesito de su ayuda.
    Tengo que armar un esquema de turnos entre 5 personas, una de ellas es la que reemplaza a las otras 4 en sus descansos. El esquema seria 30 dias de lunes a lunes.
    Como me organizo para que todos puedn trabajar y descansar parejos.
    Gracias

  56. Excel gratis says:

    Hola Emilio, Hay que limpiaar el mes seleccionando las celdas del mes y tendrías que cada año un calendario distinto, para sumar el. Aplicando la siguiente fórmula te sumaría todas las horas =SUMA(AQ11:AQ33).
    Si cambias el turno N (noche) por L (libre) le tendrías que cambiar las horas y minutos para que no los sume.
    En referencia a quedar memorizados tendría que ser a través de macros y ya sería mucho mas laborioso.

    Saludos

  57. Emilio says:

    Buenas tardes y muchas gracias por la plantilla.
    Tengo una duda, y es que, si cambio de mes, los turnos se mantienen. (Hablo del modo mensual)
    ¿Hay alguna forma de modificar la plantilla para que al cambiar de mes, se “limpie” el calendario y se queden memorizados todos los turnos de todos los meses?
    También sería genial que hubiera un sumatorio total de los turnos en el año.

    En mi caso, he modificado el turno N (noche) por L (libre) para calcular los días libres que ha tenido cada empleado en todo el año, de ahí la necesidad de hacer el cambio que indico.

    Muchas gracias de antemano 🙂

  58. Excel gratis says:

    Hola, para cambiar el formato hay varias formas, aplicando aplicando fórmulas o directamente
    Por ejemplo para cambiar el color de las Mañanas (M)
    1º Seleccionamos las celdas que deseamos aplicar el formato condicional (podemos seleccionar todo el rango que deseemos)
    2º Seleccionamos Inicio, y accedemos al menú de Formato condicional y aparecerá un menú desplegable..
    3º Seleccionamos Resaltar reglas de celdas aparece un menú con varias reglas y elegimos Es igual ponemos M y seleccionamos el color formato deseado o formato personalizado y aceptar.
    Para las noches (N), tardes (T) hacemos el mismo proceso unicamente que debemos poner un formato distinto a cada turno

  59. Nuria says:

    y para cambiar el color del relleno según turno? quisiera que por ejemplo el de maña fuese de un color y el de tarde de otro.

    Por antemano muchas gracias por tus consejos y ayuda.

  60. Excel gratis says:

    Se puede hacer de varias formas, pero si no tienes que añadir muchos festivos más puedes insertar una fila en la (fila 6)
    También puedes cambiar los festivos para otro lugar por ejemplo la columna AT el rango que desees de festivos, por ejemplo en esa columna desde la celda 8 hasta la 34
    Tienes que ir a a Fórmulas- Administrador de nombres y seleccionas Festivo y donde pone se refiere a, donde pone esto =’Modelo (anual)’!$A$2:$A$9 lo cambias por =’Modelo (anual)’!$AT$8:$AT$34 y le das aceptar

  61. Nuria says:

    Muchas gracias por la información, ahora tengo otra duda, como puedo hacer para añadir mas festivos y para que el color de relleno de los distintos turnos sea diferente.
    Muchas gracias.

  62. Excel gratis says:

    Hola Nuria,
    Hola Nueria, El libro contiene 2 hojas 2 hojas uno es el modelo anual y otro mensual, entiendo que el que te falla es el modelo menual que no está protegido y si modificas alguna fórmula el resultado tal vez no es el deseado como este caso. En la superior donde se indican los días lun, mart, mier, juev, etc. comprueba si has modificado estos datos, ya que en la fila 6 desde la celda B6 hasta la AP7 contiene fórmula. Si has modificado estos datos la celda B6 tiene que poner que es igual a la =B7 y la celda C6 =C7 ya así en las demás celdas hasta la fila AP7.

    Saludos.

  63. Nuria says:

    Hola buenos dias,
    Nose porque me salen los lunes en amarillo y no los domingos y no se como cambiar esto.
    Seguro que tendreé más preguntas espero puedan contestar
    Gracias

  64. Juan José Rodríguez Bustos says:

    Estimados:
    Podrían auxiliarme en un control por medio de macros, para tener la hora y minutos actualizados constantemente o cada minuto, sin tener que estar actualizando la página?. Esta función sería de mucha utilidad para la preparación de algunos controles de tiempo para el cálculo de rendimientos de personal, o para el cumplimiento de actividades y cálculo de duraciones de procesos. Saludos, Juan José.

You must be logged in to post a comment.