Excel Gratis

Plantillas de Excel gratis, sin contraseñas

Calendario anual en libro de Excel que muestra en la misma hoja por separado los 12 meses del año que seleccionemos (desde el año 1901 hasta 2200).

Este calendario tiene la peculiaridad que muestra debajo de las fechas las cantidades de ingresos, gastos o lo deseemos si corresponden al mismo año.

Si deseamos que nos muestre las cantidades que corresponden al año seleccionado del calendario, previamente las tenemos que introducir en la otra hoja del libro con el nombre Referencias (en la columna A se introduce la fecha desde la fila 3 y la cantidad se introduce en la columna B, misma fila). De esta forma el calendario mostrará las cantidades debajo de las fechas si éstas coinciden con el calendario del año seleccionado.

También en esta hoja en la columna D, desde la fila 3 podemos introducir ciertas fechas que pueden ser festivos, cumpleaños o cualquier otro tipo de celebración y en el calendario las mostraría con distinto formato.

Ejemplo:

En la en la fila 3 de la columna D, (celda D3) escribimos la siguiente fecha 25/5/2025, si ponemos el calendario en el año 2025, mostraría esta fecha con distinto formato, si deseamos que la muestre todos los años aplicamos la siguiente fórmula =FECHA(Anual;5;25), Anual se refiere al nombre de la celda que contiene el año, 5 es el mes y 25 el día.

Si el año estuviese en la celda W2 en la hoja calendario tendríamos que aplicar la siguiente fórmula: =FECHA(Calendario!W2;5;25).

Ya que la sintaxis de la función fecha es la siguiente: =Fecha (año; mes; día), podemos poner un número directamente dentro de la función correspondiente al año, mes o día o indicar el nombre o celda que lo contiene. Teniendo en cuenta que dentro de la función FECHA los argumentos el año se pone en primer lugar, mes en 2º  y el día en 3º lugar.

El calendario también nos muestra cada mes la suma de cantidades, semanales, mensuales y el acumulativo de todos los meses.  En el mes de febrero muestra la suma de los 2 primeros meses y en marzo la suma de los 3 primeros meses del año y así hasta el mes 12 que muestra la suma de todo el año.

Fórmulas para que muestre la suma de as cantidades de la hoja Referencias (rango B3:B5000) con la condición que el rango de fechas (A3:A5000) sean igual al Mes 1 y que el año sea igual ANUAL (anual  es el nombre de la celda que contiene el año que muestra el calendario) y se aplicó la siguiente fórmula:

=SUMAPRODUCTO((MES(Referencias!$A$3:$A$50000)=1)*(AÑO(Referencias!$A$3:$A$50000)=Anual)*Referencias!$B$3:B$50000)

Para sumar las cantidades de los meses que sean menor o igual a 2  (que correspondería a enero y febrero) se aplicó la siguiente fórmula:

=SUMAPRODUCTO((MES(Referencias!$A$3:$A$50000)<=2)*(AÑO(Referencias!$A$3:$A$50000)=Anual)*Referencias!$B$3:B$50000)

Nos devolvería el mismo resultado si en la fórmula ponemos  <3

Para sumar las cantidades de los meses que sean menor o igual a 12 (<=12), con esta condición entrarían todos los meses del año (de enero a diciembre), y se aplicaría la siguiente fórmula:

=SUMAPRODUCTO((MES(Referencias!$A$3:$A$50000)<=12)*(AÑO(Referencias!$A$3:$A$50000)=Anual)*Referencias!$B$3:B$50000)

También en la fórmula podemos hacer referencia a una celda por para que sume las cantidades que sean igual al mes que se encuentra en la celda O349 y del año siguiente al que muestra el calendario aplicamos la siguiente fórmula:

=SUMAPRODUCTO((MES(Referencias!$A$3:$A$50000)=MES(O349))*(AÑO(Referencias!$A$3:$A$50000)=Anual+1)*Referencias!$B$3:B$50000)

Si deseamos que nos muestre la suma de las cantidades del mes 1 (enero) del año siguiente al que muestra el calendario se aplicaría la siguiente fórmula:

=SUMAPRODUCTO((MES(Referencias!$A$3:$A$50000)=1)*(AÑO(Referencias!$A$3:$A$50000)=Anual+1)*Referencias!$B$3:B$50000)

Como se puede comprobar se ha cambiado en la fórmula MES(O349) por =1 (si la celda contiene una fecha dia/mes/año dentro de la fórmula pondríamos  =MES(O349)), si tiene contiene un número  del 1 al 12, sólo ponemos =0349 y devolvería el mismo resultado, como se indica a continuación:

=SUMAPRODUCTO((MES(Referencias!$A$3:$A$50000)=O349)*(AÑO(Referencias!$A$3:$A$50000)=Anual+1)*Referencias!$B$3:B$50000)

Para sumar los días de la semana en cada fila se aplicó la función =SUMA(y rango a sumar), por ejemplo para sumar las cantidades del rango B8:V8 se aplicaría la siguiente fórmula: =SUMA(B8:V8).

 En formato condicional podemos cambiar el formato que muestra para los días que coinciden con las fechas de la columna 3 (hoja Referencias).

La siguiente imagen muestra a modo de ejemplo el mes de enero del año 2025, así como en tamaño más pequeño el mes anterior y posterior a éste, así como las cantidades que corresponde a dicho mes (clic para ampliar).  El libro de Excel la hoja muestra en la misma los 12 meses.

clic para descargar Calendario anual suma cantidades

Hojas de Excel gratis