Excel Gratis

Plantillas de Excel gratis, sin contraseñas

Para comprobar si las las condiciones son verdaderas o falsas así como la realización de comparaciones lógicas entre expresiones son elementos comunes de varias tareas.
Aquí dejo algunas fórmulas que pueden servir de ayuda o referencia usando la función SI, con la cual comprueba si la condición se cumple (nos muestra el valor verdadero y si no se cumple muestra el valor falso).
Ejemplo simple la función es =SI
La celda que vamos a comprobar si cumple la condición es la celda A1
Si la cantidad que hay en la celda A1 es mayor de 1000 multiplica A1*21%, en caso de no cumplirse multiplica A1*2% el resultado nos lo devuelve en la celda donde pongamos la siguiente fórmula:
=SI(A1>1000;A1*21%;A1*2%)

Otro ejemplo dentro del misma fórmula. En este caso dependiendo de la nota que hay en la celda A1 nos mostrará los siguientes valores en el caso de que sea verdadero:
Si la celda A1 se encuentra en Blanco dejará la celda en blanco
Si la nota es <5 (suspenso) Si la nota es <7 (aprobado) Si la nota es <9 (notable) Si la nota es <10 (sobresaliente) Si la nota es =10 (matrícula de honor) Debemos de colocar las condiciones por orden, según se indica en la siguiente fórmula: =SI(ESBLANCO(A1);””;SI(A1<5;"suspenso";SI(A1<7;"aprobado";SI(A1<9;"Notable";SI(A1<10;"sobresaliente";SI(A1=10;"matrícula de honor";""))))))
En el caso de que no se cumpla ninguna de las condiciones donde ponemos la fórmula dejaría la celda en blanco.
Al poner varias condiciones en una fórmula debemos tener en cuenta que devuelve la primera que se cumple.
Ejemplo:
Si en la fórmula anterior donde hay puesto la condición SI(A1<5;"suspenso”; se pone SI(A1<10;"sobresaliente"; si la nota que se pone en A1 es inferior a 10 devolvería siempre sobresaliente ya que no leería las demás al cumplirse, únicamente si la nota es igual a 10 devolvería matrícula de honor. Podemos poner una doble condición usando la SI acompañada de la función Y La siguiente fórmula nos devolvería el mismo el mismo resultado que la anterior fórmula aunque lleva una doble condición para aprobado, notables y sobresaliente: =SI(ESBLANCO(A1);””;SI(A1<5;"suspenso";SI(Y(A1<7;A1>4,9);”aprobado”;SI(Y(A1<9;A1>6;9);”Notable”;SI(Y(A1<10;A1>8,9);”sobresaliente”;SI(A1=10;”matrícula de honor”;””))))))
Otras fórmulas

La siguiente fórmula si se cumplen todas las condiciones rango A4 hasta H4 nos devuelva Todo correcto en caso contrario No está todo correcto
=SI(Y(A4=1;B4=2;C4=3;D4=4;E4=5;F4=6;G4=7;H4=8);"Todo correcto ";" No está todo correcto")

La siguiente fórmula si se cumplen todas las condiciones rango A6 hasta H6 y A4 hasta H7 en el caso de cumplirse todas las condiciones nos devuelva Todo correcto en caso contrario No está todo correcto
=SI(Y(Y(A6=1;B6=2;C6=3;D6=4;E6=5;F6=6;G6=7;H6=8);A7=9;B7=10;C7=11;D7=12;E7=13;F7=14;G7=15;H7=16);"Todo correcto";" No está todo correcto")

La siguiente fórmula comprueba si el valor de la celda A14 es un numérico, en caso verdadero multiplica A14*5, de lo contrario devuelve no es numérico
=SI(ESNUMERO(A14);A14*5;" no es numérico ")

La siguiente fórmula comprueba si la celda A14 de la hoja3 es numérico.
=SI(ESNUMERO(Hoja3!A14);"Es numérico";" no es numérico ")

La siguiente fórmula tiene que cumplir una de las 2 condiciones que en la celda A15 tenga un valor numérico o que B15 sea igual a 5, si se cumple uno de las condiciones multiplica la celda 5*10, si no se cumple ninguna condición devuelve No se cumplen ninguna condición.
=SI(O(ESNUMERO(A15);B15=5);5*10;" No se cumplen ninguna condición")

La siguiente fórmula se aplica una condición que sume el rango de celdas desde A1 hasta A15 y si la suma es inferior a 15 devolverá inferior a 15 si la suma es mayor nos devolverá el resultado de dicha suma, fórmula:
=SI(SUMA(A1:A15)<15;"inferior de 15 ";SUMA(A1:A15))

La siguiente fórmula tiene 2 condiciones en el caso de cumplirse nos devuelve 0, en caso contrario suma el rango A2:A150
=SI(Y(ESBLANCO(A1);ESBLANCO(B1));0;SUMA(A2:A15))

La siguiente sólo se tiene que cumplir una condición para que haga la suma
=SI(O(ESBLANCO(A1);ESBLANCO(B1));0;SUMA(A2:A15))

La siguiente fórmula si hay un error en la división de A5/B5 nos devolvería 0, en caso contrario haría la división:
=SI(ESERROR(A5/B5);0;A5/B5)

En las fórmlas indicadas se pueden usar los siguientes operadores:
= para preguntar si dos valores son iguales,
> para saber si un valor es mayor que otro,
< para preguntar por menor, >= con este podremos conocer si es mayor o igual,
<= preguntamos por menor o igual, o si deseamos mirar sin son diferente utilizaremos <>

Fórmulas excel