Excel Gratis

Plantillas de Excel gratis, sin contraseñas

Aquí dejo algunos ejemplos que nos pueden servir de ayuda o referencia para sumar rangos de celdas que cumplan ciertas condiciones en referencia a ciertas fecha y otros criterios.

La mayoría de las cantidades se encuentran en la columna B (rango B2:B25). La columna está identificada por una letra en la parte superior (sentido horizontal de la hoja), el número identifica la fila (sentido vertical).

Aquí dejo algunos ejemplos que nos pueden servir de ayuda o referencia para sumar rangos de celdas que cumplan ciertas condiciones en referencia a ciertas fecha y otros criterios.
La mayoría de las cantidades se encuentran en la columna B (rango B2:B25). La columna está identificada por una letra en la parte superior (sentido horizontal de la hoja), el número identifica la fila (sentido vertical).

EJEMPLOS:

Deseamos sumar las cantidades de la columna B el rango B2 hasta B25 utilizando la SUMA. Primero en una celda vacía ponemos el signo igual (=), ya que todas las formulas comienzan así y aplicamos la siguiente fórmula en la celda: =SUMA(B2:B25) y pulsamos la tecla ENTER y nos devolvería la suma de las cantidades que se encuentran en el rango a sumar.
En el caso anterior se han sumado las celdas de la columna B, si deseamos sumar el mismo rango de la columna C aplicaríamos la siguiente fórmula: =SUMA (C2:C25)
Para sumar el rango de la columna B y C aplicamos la siguiente fórmula: =SUMA(B2:C25)
También obtendríamos el mismo resultado con la siguiente fórmula: =SUMA(B2:B25;C2:C25)
Al rango B2;C25 también que nos sume el rango G5:G15, aplicamos la siguiente fórmula: =SUMA(B2:B25;C2:C25;G5:G15) o =SUMA(B2:C25;G5:G15)
También podemos realizar distintas operaciones empleando distintos operadores aritméticos para sumar, resta, multiplicación, división, etc. entre distintos rangos, como por ejemplo:
Para restar la suma del rango (B2:B25) menos la suma del rango (C2:C25), podemos emplear la siguiente fórmula: =SUMA(B2:B25)-SUMA(C2:C25), si deseamos multiplicar dichos rangos: =SUMA(B2:B25)*SUMA(C2:C25)

SUMAR LAS CANTIDADES QUE CORRESPONDEN AL MES Y AÑO QUE INDIQUEMOS EN LA FORMULA

Ejemplo: sumar las cantidades del mes 12 (diciembre)
Las fechas se encuentran en la columna A rango (A2:A25) las cantidades columna B (rango B2:B25), aplicaríamos la siguiente fórmula matricial:
=SUMA(SI(MES(A2:A25)=12;B2:B25)) después de editarla pulsar al mismo tiempo las teclas CONTROL + SHIFT + ENTER y tendría que cerrarse la fórmula entre corchetes {} y tendría que quedar así: {=SUMA(SI(MES(A2:A25)=12;B2:B25))}
La siguiente fórmula también matricial suma las cantidades del mes 12 del año 2016 {=SUMA(SI(MES(A2:A25)=12;SI(AÑO(A2:A25)=2016;B2:B25;);0))}
Compruebe en las columnas de fechas contienen fechas y las cantidades contienen números en algunas fórmulas daría error.
Fórmulas para sumar las cantidades del mes 12 (diciembre) {=SUMA((MES(A2:A25)=12)*(B2:B25))} (fórmula matricial)
=SUMAPRODUCTO((MES(A2:A25)=12)*B2:B25)
=SUMAPRODUCTO(--(MES(A2:A25)=12);--(B2:B25))

Imagen 1 ejemplo (clic para ampliar)

formula-1

PARA SUMAR CANTIDADES SEGÚN EL MES O AÑO QUE INDIQUEMOS

Formula suma las cantidades que correspondan al mes 12 (diciembre) del año 2016
=SUMAPRODUCTO(--(MES(A2:A25)=12);--(AÑO(A2:A25)=2016)*B2:B25) también: =SUMAPRODUCTO((MES(A2:A25)=12)*(AÑO(A2:A25)=2016)*B2:B25)
Suma las cantidades del mes 12 y el año sea mayor o igual a 2016 y año menor o igual a 2019
=SUMAPRODUCTO((MES(A2:A25)=12)*(AÑO(A2:A25)>=2016)*(AÑO(A2:A25)<=2019)*(B2:B25))

SUMA LAS CANTIDADES CRITERIOS DE FECHAS Y OTROS

Suma las cantidades de la columna B (rango B2:B25), fecha columna A (rango A2:A25) menor o igual a 30/12/2016.
=SUMAR.SI(A2:A25;"<="&FECHA(2016;12;30);B2:B25) también podemos emplear la FUNCIÓN SUMAR.SI.CONJUNTO:
=SUMAR.SI.CONJUNTO(B2:B25;A2:A25;"<"&FECHA(2016;12;30))

Suma las cantidades de la columna B (rango B2:B25), fecha columna A (rango A2:A25), mayor 30/12/2015 y la cantidad columna B (rango B2:B25) sea mayor 2. =SUMAR.SI.CONJUNTO(B2:B25;A2:A25;">30/12/2015";B2:B25;">2")

Suma las cantidades de la columna C (rango C2:C25), criterios Fecha “<=” a la celda A2 y “<=” celda A9.
=SUMAR.SI.CONJUNTO(C2:C25;A2:A25;">="&A2;A2:A25;"<="&A9)

Suma las cantidades con los siguientes criterios que la fecha sea mayor o igual al MIN del (rango A2:A9) y menor o igual al valor MAX del (rango A2:A9)
=SUMAR.SI.CONJUNTO(C2:C25;A2:A25;">="&MIN(A2:A9);A2:A25;"<="&MAX(A2:A9))

Imagen ejemplo 2 del libro que puede descargar debajo de la misma
formulas-2

Descargar libro de fórmulas

Hojas de Excel gratis